Back to overview
Degraded

Mollie is down

Apr 3, 2026 at 3:44pm UTC
Affected services
Mollie

Resolved
Apr 3, 2026 at 5:17pm UTC

Mollie recovered.

Created
Apr 3, 2026 at 3:44pm UTC

Mollie is degraded.